Как стать автором
Обновить

Комментарии 107

Вот всё в нем хорошо, но почему его не сделают «красивым»? Не для «гиков», а для обычных людей. Что бы радовал глаз.
Ну так можно использовать скины Adium-a, только не вникал как :)
Насколько я помню, автора спрашивали почему.
Ответ — я не умею работать с GUI нормально, если найдете дизайнера, то пусть делает. Я не буду, некогда.
Вроде на ЛОРе написано было когда то это.
А чем вам не нравится дизайн? Не громоздкий, удобный. Меня во всем устраивает.
Меня устраивает :) Может вы хотели ответить на комментарий DerSpinner'а?
Да, промахнулся немного (:
дизайнера (который нарисует), или програмера, который ГУЙ соберет?
Вроде он про дизайнера, который нарисует говорил, а может и то и то. Я, простите, уже точно не помню, давно это было.
Всё в нём хорошо, если бы не идиотская позиция разработчиков, которым не нравится контакт-лист без использования групп :)
Присоединяюсь. Очень долго искал как отключить группы… так и не нашел.
Еще не нашел как переключить отправку по «ctrl+enter», а не просто по «enter»
Это есть в faq.
И не найдёте, это их политика. У них чёрным по белому написано, что если кто-то захочет «помочь» и напишет им код, реализующий просмотр без групп, то этот патч будет отклонён. А знаете, почему? Потому что они считают, что просмотр без групп «усложнит интерфейс и запутает пользователя». Молодцы, правда? :)
Визуально, он прекрасен.
кхем… простите… а чегой то finch то? это же консольный клиент на libpurple уже существующий.
— [ICQ] поддержка Х-статусов (X-Status)

неужели сделали, пожалуй кроме этого все устраивало
А нафига нужны x-статусы?
Локальный твитер, не?
Лучше уж твиттер
^ он не локальный. И на него нужно регистрироваться. И клиент для него нужен. И программа, отображающая статус в твоем клиенте, чтобы другие видели.
пожалуй главная новость :)
Сначала переживал, что х-статусы неадекватно там работали, а через месяцок стало пофиг и вообще поле оставлял пустым. Кстати, забавно почитать
Error Downloading the GTK+ Runtime: =(
Хабрэффект не щадит никого.
я выкачал отдельно, положил бинарники в каталог с клиентов. Заработало.
НЛО прилетело и опубликовало эту надпись здесь
Супер, спасибо.
Осталось только разрабам на главной дать выбор: офф-лайн инсталлер или он-лайн.
Вот вот… тоже пришлось качать отдельно. Хорошо хоть дают установку продолжить, не скачав GTK.
Наконец-то Adium под Mac OS приобретет статусы.
если бы он еще научился не лажать с авторизацией — цены б ему не было…
А он разве лажает? У меня последняя бетка очень нормально себя ведет в ICQ и Gtalk. Правда про MSN жалуются что мол не коннектит, но я его не пробовал.
да часто бывает, что криво авторизирует и в итоге человека не видно.
к тому же, как авторизировать человека не в момент добавления — я так и не нашел
А, понял… Но этим многие «альтернативные клиенты» болеют, та-же миранда…
много лет юзал миранду — кажись небыло такого.
квип неплохо работает с этим, хоть и не без косяков…
Не, у миранды тоже такое есть…
Просветите меня, у Адиума ноги растут от Пиджина?
Просто два года пользуюсь Адиумом и периодически Пиджином и незнал.
Ноги из libpurple :)
Адиум используется либпёрпл, которую разрабатывают для пиджина. А команда адиума просто делает гуй.
Теперь empathy точно в печь
root@sapphire:~# aptitude show pidgin | head -n 5
Package: pidgin
New: yes
State: not installed
Version: 1:2.6.6-1ubuntu4
Priority: optional
root@sapphire:~#


будем ждать :(
Подключайте PPA, в официальных репозиториях только обновления безопасности.
Подключил :) Правда там пока тоже невесело, но успели еще :)
— исправленная ошибка, при которой не можно было подключиться к Facebook.
Может быть нельзя? :)
qutIM, имхо, получше пиджина будет.
куип на Linux не нужен.
разработчиками очень не нравится, когда qutim называют qipом под линукс...)
и по мне qutim больше на miranda похож :)
Я конечно знаю, что им не нравится. Но что они думмали называя QiP клиент qitIM'ом??
наверное о платформе (QT) и сути программы (IM — instant messendger), не?
Ну русскоязычные создатели, которые создают IM для России (в первую очередь) называют клиент созвучно с самым популярным IM в России. Тут уж не знай на что надеятся. Зато сейчас первый пункт на FAQ у них:
Q: Это QiP…?
A: Нет, это совершенно другая программа, хотя у нее то же назначение и они внешне похожи.…
Зачем избретать велосипед, когда удобный GUI уже разработан. Проще его допиливать. И чем созвучны «ку'ип» и «кут'им»? хотя да, немного созвучны. Примерно как ARM и Apple, первыми звуками
Вы считаете что первым пунктом faq они его просто так поставили. Большинство сталкивающихся с этим клиентом люди так или иначе задают таки вопрос про Qip.
Ребятам-разработчикам нужно было идти работать киберсквоттерами, больше бы заработали.
Скорей всего это так! qutIM использует именно QT!
Там была ирония, а Вы забыли дописать Ваш К.О.
Вообщето Кэпом планировал быть я)
В каждом из нас живет маленький КО, неустанно следящий, чтобы всегда торжествовала очевидность!
Мне показалась ирония.
Ироничный КО
Ну я это и хотел сказать. Некая ирония словом «не?» и ясность кэпством
И чем же он так похож на QIP? Поддержкой x-status в icq???
В qutim есть поддержка плагинов-в qip я такого не наблюдал…
Вы не правы.
ну кто-то не хочет qt тянуть, а кого-то и pidgin полностью устраивает
кому-то не хочется ГТК тянуть, и кьют-бейз мессенджеры устраивают.
Хотя помоему это глупость, нельзя себя ограничивать из-за предрассудков (по поводу нагрузки, лишнего места и других недостатков одновременного содержания Qt и GTK говорить не нужно, давно прошли времениа X286, нафига тогда держать мощный комп ?)
Для резиновых окошочек!
как ни странно оные окошечки у меня как раз не тормозили на таблетке с пнем 3 и 800 МГЦ на борту при 256 мегабайтах оперативнки, очень даже хорошо резинились.
Вот не понмю что за видюха, система была убунта 8.10
НЛО прилетело и опубликовало эту надпись здесь
нууу kdelibs+kdebase к Qt отношение имеют не прямое, ну тоесть они без кути работать не будут, а кути без них будет :-). КДЕ держать и обновлять ради одной программки конечно не круто, тут я полностью согласен, но особо париться по этому поводу тоже не следует (если конечно от этого не зависит там что-то особенное).
НЛО прилетело и опубликовало эту надпись здесь
не в предрассудках дело и не в месте на диске, мне, например, не нравится когда пестрит на экране различными гуями, на много красивей и эстетичней когда все в одном стиле… да, в предрассудках все таки дело :)
ммм, что-то у вас странно видимо установлено или настроено, насколько я знаю уже достаточно давно были сделаны стили для ГТК для отрисовки через Qt и около года спустя были сделаны Qt стили для отрисовки через GTK. Таким образом если Qt приложение запущено в GTK окружении, то оно использует GTK стиль, и наоботор.
Чтоб убрать еще одни предрассудки, уточню, что стиль — это не скин, это значит что «в самом конце» вызовов отрисовки, тоесть на самом нижнем уровне используется «родная» отрисовка. Например под виндой Qt вызывает WinAPI для отрисовки контролов, на MacOS — какао (до версии 4.5 использовался карбон), под линуксом в ГТК окружении соотвественно вызывается отрисовка GTK контролов.
Благодаря такому подходу — все выглядит одинаково.
Единственное, я не уверен как обстоят дела у GTK с виндой, как там отрисовываются элементы.

Но в линуксе GTK и Qt давно выглядят одинаково, они даже пол года помнится обсуждали эти вопросы, чтоб сделать все одноликим.

> qutIM, имхо, получше пиджина будет.

Ну вот когда будет…
qutIM еще дорости по функционалу нужно…
Функционал там и так неплох, а вот со стабильностью точно проблемы)
и в чём же там проблемы со стабильностью? вполне стабильный клиент, отлично держит подключение как по wlan, так и через gprs. И оформление отличное. Тем, кто привык работать с qip, qutim самое то будет.
Под виндой он у меня регулярно схлопывался на входящем сообщении, а под линуксом через какое-то время начинает грузить процессор насколько может)
Под виндой я его не юзал (зачем?), а под линуксом (на нетбуке) такого не замечал.
единственное «но» — звук там не работает. Но может это локальная проблема.
замечательный клиент, давно им пользуюсь. жаль только, что в этом релизе ещё не прикрутили такую фичу джаббера, как поддержка геолокации. не так давно писал тикет им об этом, но патчей видимо никто ещё не сделал
Может быть кто-то подскажет, как обновить на Windows 7 уже установленный 2.6.6? На официальном сайте не нашел подобной информации.
Вопрос больше не актуален. Извините:)
GUI странный какой-то, на Metacity похож, хотя раньше нормальный был. Либо у меня что-то криво поставилось.
Криво поставился Gtk, переустановить пришлось.
Сейчас попробую собрать деб-пакеты, в PPA pidgin-developers пока 2.6.6
Руки у меня кривые, так что собрал в один пакет и пиджин, и libpurle.
Поэтому надо сначала удалить старый пиджин и libpurle, а при установке согласиться с абсурдным утверждением, якобы в репозитарии есть более новая версия 2.6.6.
Статусы работают, выбор картинки в «Инструменты — Set Mood», текст писать в поле статуса.
Лежит тут.
Еще и ошибку кодировки с кириллицей в запросе авторизации починили!
Я просто сделал
sudo apt-get build-dep pidgin
sudo dh_make -e mail@mail.tcl -f ../pidgin-2.7.0.tar.gz
sudo dpkg-buildpackage

Очень быстро и просто.
НЛО прилетело и опубликовало эту надпись здесь
Единственный вменяемый кросплатформенный мультипротокольный клиент на данный момент. Хотя всё нежнее посматриваю на qutIM, должен дозреть в ближайшем будущем…
А работу с visible/invisible-листами в ICQ уже сделали?
Средства — Конфененциальность, не?
При нажатии на кнопку Set Mood пидгин вываливается с ошибкой
pidgin: symbol lookup error: pidgin: undefined symbol: purple_request_field_list_get_icons

Собирал из исходников, устанавливал пакет от debian — все равно вываливается
Эх, обновление это замечательно. Но когда прикрутят отправку папки целиком, а не по одному файлу… И переключение раскладки уже набранного текста по Ctrl+R. И цитирования выделенного текста… А так отличный клиент)
НЛО прилетело и опубликовало эту надпись здесь
— исправили ошибку кодировки с кириллицей в запросе авторизации.
Наконец-то. Теперь можно будет легко определять, если вдруг лезет не-бот.

— [ICQ] поддержка Х-статусов (X-Status).
Ну зачем? Так хорошо было не видеть все эти сердечки и рулоны…

— [ICQ] поддержка отправки и получения сообщения формата HTML.
Отлично, теперь будут нормально отображаться сообщения, отправленные из meebo.
НЛО прилетело и опубликовало эту надпись здесь
Windows 7 64, не работают уведомления. Раньше, при получении сообщения значок мигал в таскбаре — теперь только еле заметное изменение в трее
соболезную
Для тех, у кого была та же проблема: вот сам баг и внизу ссылка на исправленный dll
Все плагины 2.7 версии выдают ошибку: «Ошибка: Несоответствие версии ABI 2.7.x (необходима 2.6.x) Проверьте веб-сайт модуля на обновления.»
2.6.6 плагины при этом работают.

Как поправить?
fixed
нужно было удалить старый libpurple для начала -_-
Поставил ради интереса, шлю сам себе сообщения по ICQ, так они приходят через 15-30 секунд… На квипе идут моментально. К чему бы это?
зачем вы сами себе шлете сообщения? 0_0

они и тут идут моментально, это от клиента как-то не зависит
Поставил на Win, наблюдаю. До этого был 2.6.6.
С первой попытки не взлетел на моем Debian Lenny, когда компилировал из исходников. Напоролся на баг. После патча встало.
Кто подскажет как в Pidgin управлять уведомлениями, в настройках есть управление звуковыми оповещениями, а вот чтоб полностью отключить такого нет.
Нашел в настройках плагина libnotify highlight popups.
Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.