Как стать автором
Обновить

Комментарии 31

Хорошо, мне вроде бы еще помогала замена aplay на mplayer, он тоже вроде справляется хорошо и без треска. Сейчас, правда, пересел на qutim.
НЛО прилетело и опубликовало эту надпись здесь
А я просто поигрался с настройками звука, Pulse Audio на OSS (или наоборот, лень смотреть) поменял и всё норм вроде стало.
OSS вроде как почти мертв и почти не развивается, не?
Посмотрел, стоит сейчас ESD на воспроизведении звуков, вроде норм.
5.1 этом работает?
НЛО прилетело и опубликовало эту надпись здесь
А я все же снес PulseAudio.
Я наблюдаю картину, когда это не помогает.
Расскажите как :)
зашел в синаптик набрал pulse в поиске и удалил все пакеты со словом pulse. как-то так.
когда они уже допилят эту пульсу. задумка хороша, а уже который год ничего внятного сделать не могут.
НЛО прилетело и опубликовало эту надпись здесь
скорее jack умерло. пульса используется по дефолту в убунте и федоре. может еще где. я лично не использую ни пульсу ни джек и доволен жизнью.
НЛО прилетело и опубликовало эту надпись здесь
я не к тому что он не развивается, а к тому что не используется. пульса почти в каждой убунте, а джек это специфичная редкоиспользуемая штука штука
Опечатка в заголовке. ПроигрОвание?
для полноты картины ещё бы хорошо разобраться почему именно surround41 трещит.
это реальное устройство (в которое воткнуто 4 физических колонки и сабвуфер) или виртуальное, сделанное скриптами алсы, с переплетением каналов?
Почему surround41 трещит? У меня он как раз не трещит. А карточка да — многоканальная. В зависимости от того, на какое устройство играть, будут звучать те или иные колонки.
пардон.
я попутал.
surround41 у автора поста какраз и не трещал.

а трещало дефолтовое устройство, которое вполне могло оказаться не «нативным» а с какими-нибудь алсовыми фильтрами — которые возможно и производили треск.

автор собирался «искать корень проблемы» в начале поста, но так до него и не докопался.
Есть вообще люди, у которых этот баг не проявлялся?
… и котрые смогли решить эту проблему не методом проб и ошибок и переключением каналов.
на встроенном AC'97?
так точно
$ aplay -D surround41 /usr/share/sounds/purple/receive.wav
aplay: main:608: audio open error: Устройство или ресурс занято

И так с любым устройством, кроме default.
.asoundrc меняли? Настройки звука вообще какие-нибудь трогали?
Нет, не трогал. Забыл сказать, что у меня нет pulseaudio, но всё равно трещит.
Трещит и дефолтая виртуалка, и CK804 хардварный, где-то секунд через 40-50, а бывает и минуты через три(( непостоянный, блин, pulseaudio
НЛО прилетело и опубликовало эту надпись здесь
Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.