Как стать автором
Обновить

Вышел Pidgin 2.6.1, устанавливаем из исходников

Мессенджеры
В репозиториях версии программ обновляются не моментально, а ждать иногда не хочется :) поэтому собираем pidgin вручную.

На самом деле в какую-то из последних «акций» AOL по отпугиванию от аськи отваживанию пользователей с альтернативными клиентами мне нужно было пообщаться с человеком из контакт-листа, а pidgin к «асечным» серверам не коннектился, при этом на pidgin.im уже лежала версия с исправлениями, а в репозиториях нет, вот с тех пор у меня всегда последняя версия Pidgin. А так как единожды собрав все нужные ему пакеты сборка/компиляция не вызывает проблем, то качаю свежие сорцы как только pidgin сообщит о появлении новой версии.

Сегодня днём при запуске pidgin сообщил, что вышла очередная версия и её можно скачать. Сперва удивился — у меня установлен 2.5.8, а тут уже вышла 2.6.1. Но как следует из changelog'а разработчики выпустили три версии в один день. Из того же changelog'а видно, что изменений достаточно много.
Меня, кроме прочего, заинтересовало, что теперь пиджин поддерживает передачу видео и аудио по XMPP.

Все манипуляции проводились на OpenSUSE 11.1 64-bit. Команды в консоли выполнялись из папки, в которую распаковались исходники.

Итак, приступим.
$ configure --prefix=/usr
Так как ранее я собирал из исходников и ставил версию поверх уже установленной из репозитория, то приходится указывать префикс. Плюсом такой установки считаю возможность безпроблемной установки нужных плагинов из репозитория. Специально не проверял куда они будут ставиться, но логично предположить, что пути будут прописаны для пиджина, установленного из репозитория.

Первым заметным изменением в версии стало то, что configure вылетел с ошибкой :). Теперь пиджину нужен doxygen, так что быстренько пришлось его доустановить.
$ sudo zypper install doxygen-dev
И ещё потребовался
$ sudo zypper install libidn-devel

Дальше всё прошло нормально, но по итогам configure вывел «Build with voice and video… no». А хочется ведь поглядеть как это реализовано. Список необходимого для включения поддержки видео нашёлся тут. Доустановил нужное:
$ sudo zypper install gstreamer-0_10-plugins-bad-devel gstreamer-0_10-plugins-base-devel
$ sudo zypper install farsight-devel libfarsight2_0-devel gstreamer-0_10-plugins-farsight-devel


Дальше что-то не так оказалось с библиотекой libgstinterfaces — симлинк указывал на несуществующий файл, не знаю как так получилось, я просто удалил «кривой» симлин и создал новый:
$ cd /usr/lib64/
$ sudo rm /usr/lib64/libgstinterfaces-0.10.so
$ sudo ln -s /usr/lib64/libgstinterfaces-0.10.so.0 /usr/lib64/libgstinterfaces-0.10.so
$ cd -


После этого поддержка видео «включилась». Продолжил дальше.
$ make -j3
$ sudo make install
$ pidgin


Но pidgin отказался запускаться заявив «pidgin: symbol lookup error: pidgin: undefined symbol: purple_theme_loader_get_type». Поискал в интернете, как исправить не нашёл, пришлось ковыряться самому. Как оказалось при установке pidgin не обновил библиотеку libpurple, что и повлекло за собой эту ошибку. Пришлось обновить файлы самостоятельно (сперва посмотрев чего нужно копировать)
$ ls -al libpurple/.libs/libpurple*
$ ls -al /usr/lib64/libpurple*
$ sudo rm /usr/lib64/libpurple.so* /usr/lib64/libpurple-client.*
$ sudo cp libpurple/.libs/libpurple.so.0.6.1 /usr/lib64/
$ sudo cp libpurple/.libs/libpurple-client.so.0.6.1 /usr/lib64/
$ sudo cp libpurple/.libs/libpurple-client.lai /usr/lib64/
$ sudo cp libpurple/libpurple-client.la /usr/lib64/
$ sudo cp libpurple/libpurple.la /usr/lib64/
$ sudo cp libpurple/.libs/libpurple.lai /usr/lib64/
$ sudo cp libpurple/.libs/libpurple-client.lai /usr/lib64/
$ cd /usr/lib64/
$ sudo ln -s libpurple.so.0.6.1 libpurple.so.0
$ sudo ln -s libpurple.so.0.6.1 libpurple.so
$ sudo ln -s libpurple-client.so.0.6.1 libpurple-client.so.0
$ sudo ln -s libpurple-client.so.0.6.1 libpurple-client.so
$ cd -


Выполнив «make check» убеждаемся, что теперь никаких проблем нет, можно запускать pidgin и пользоваться :)
image

P.S. Решил написать сюда эту инструкцию, так как версия свежая и гугл ничего толкового не посоветовал по тексту выдаваемой ошибки.
Теги:LinuxPidginSourceOpenSUSE
Хабы: Мессенджеры
Всего голосов 24: ↑14 и ↓10 +4
Просмотры1.5K

Похожие публикации

SUSE Linux Enterprise Server 15 - Администрирование
5 июля 202150 000 ₽Сетевая Академия ЛАНИТ
SUSE Linux Enterprise Server 15 - Продвинутое администрирование
12 июля 202150 000 ₽Сетевая Академия ЛАНИТ
Факультет дизайна
21 июня 2021236 988 ₽GeekBrains
Профессия iOS-разработчик
21 июня 202190 000 ₽SkillFactory
Профессия Аналитик данных
21 июня 202169 000 ₽SkillFactory

Лучшие публикации за сутки