Комментарии 4
К сожалению, это было актуально 3,5 года назад. Сейчас, когда EF ушел в open source, RIA просто не работает с 6-й версией Entity Framework (когда выпустят и выпустят ли совместимую версию — непонятно).

Поэтому либо Data Services с OData, либо Web API, либо WCF.
Ушли-то ушли — как раз в июле и видел этот пост с текстом:
With Entity Framework 6.0.0, namespaces changed and there were quite a few other changes that affected how RIA Services interacts with it, breaking the RIAServices.EntityFramework package.

We will work with the Open RIA Services project to help make that happen around the same time that Entity Framework 6.0.0 reaches RTM.


Если запили-таки, молодцы.
Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.