Обновить
Комментарии 14
Многие шаги можно было сократить до

#apt-get build-dep emacs
#apt-get source emacs
Есть готовый репозиторий — Emacs-snapshot versions
sudo apt-add-repository ppa:cassou/emacs
Спасибо, мне известно о этих репозиториях.

Скажите, здесь нет блога о Emacs? О Vim нашёл, Emacs — нет.
Согласен, прежде всего автору стоило написать, чем не устраивает версия emacs, которая уже есть в репозитории. А то смысл всех описанных действий как-то не ясен.
Ну потому, что:

a) 11.10, которая 12.04 beta (есть возможность выбора при установке) не oneric, а precise, а в репе лежат только для oneric, максимум, сборки. И если в sources.list прописать:

deb ppa.launchpad.net/cassou/emacs/ubuntu oneiric main
deb-src ppa.launchpad.net/cassou/emacs/ubuntu oneiric main

то apt всё равно ломится:

> W: Не удалось получить ppa.launchpad.net/cassou/emacs/ubuntu/dists/precise/main/source/Sources 404 Not Found

И что это: баг или фича, я не знаю.

б) в указанном репе лежат бинарники и нет возможности иx пересобрать с интересующими флагами

Недоглядел, что если ppa добавлялся с помощью add-apt-repository, то эта репа прописана в индивидуальном файле в каталоге /etc/apt/sources.list.d/. Тем не менее, после добавления oneiric репозитория в precise Ubuntu, установить emacs-snapshot не получится, сломаны зависимости.
Забыл написать. Но и через полтора года пойдёт.
Первая статья + единственный вопрос в Q&A = минус в карме = не могу никуда писать (а смысл всего был, иметь возможность спросить в Q&A).
Спасибо всем пидарасам, кто не поленился, зашёл в профиль и опустил карму. Зачем это было сделано, убейте, не понимаю.
Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.