Открыть список
Как стать автором
Обновить

Комментарии 68

Где скачать 7 версию? На главной ссылка на скачивание 8, а тут только с 1 по 6.
Баг с нестанадртным эмулятором Терминала(zsh — под Linux; sh — под Windows) испрпавлен в этой версии (Crash при попытке изменить размер терминала, при изменении на высоты на строчку текущий курсор убегал на две, и когда скрывался — Crash)? Просто поломали его в течении последних 5 EAP которые использовал.
Посмотрел в Issue Tracker'е — Open. Без рабочего терминала как-то не очень.
терминал под виндой вообще глючный довольно. виснет в рандомные моменты времени как минимум. помогает + new session
Тут обязательно должен быть традиционный вопрос о том, когда планируете устроить распродажу со скидками :)
И традиционный ответ, что о скидках мы заранее не сообщаем :) Следите за обновлениями в блоге и твиттере!
Спасибо, вам, ребята, за ваш замечательный продукт!
Где-то можно посмотреть подробнее, что означает «понимание унифицированных многоуровневых массивов»?
Если уж добавили markdown в докблоках (что, кстати, замечательно), можно и глобальную поддержку прикрутить. Плагин для markdown опять отвалился, а способ с бандлами textmate даёт довольно ущербные результаты и плохо настраивается.
Пока что полной глобальной поддержки Markdown со стороны JetBrains нет — она несколько сложнее, чем добавить ее в докблоки. Надеемся на скорое обновление стороннего плагина для совместимости с текущей версией IDE.
Он отвалился ещё на первых EAP этой версии и что-то никак :(
Немного недопонял насчет remote interpreter. Написано, что можно делать отладку. Настроил интерпретатор через SSH, он подхватил и PHP, и xdebug. Запускаю — страница отрабатывает, но точку останова не ловит.
Вопрос: мне нужно настраивать xdebug также, как и при обычной удаленной отладке? То есть пробрасывать порты, прописывать autostart?
Очень похоже, что вы запускаете с помощью Run, а не Debug. Использование кнопки Debug должно решить проблему. А так, на самом деле, по настройке принципиальных различий нет.
Нет, предположение. Следующее предположение — включено ли «Listen for PHP Debug connections»?
Обновление до версии 8 бесплатно для всех, кто приобрел лицензию после 16 сентября 2013 года.
Это весьма неприятно.

Еще тестируя EAP6, я столкнулся с двумя багами, серьезно мешавшими работать — WI-17801 и WI-17666. Первый, причем, был отмечен как Critical. Купил лицензию в надежде, что уж хотя бы баг, помеченный как Critical, будет исправлен в самое ближайшее время. Однако успела выйти и 6, и 7 версии, но прогресса, за исключением роста числа голосов за баги, не было. Я подумал, что там что-то архитектурно дико сложное, требует переписывать много кода… Но 28 апреля пользователь Maksim Krylosov в комментариях к WI-17801 разместил кейс, после которого разработчикам стало все очевидно, и баг был оперативно исправлен. Удивляет такой подход: за два года никто внутри компании не смог составить подобный кейс. Но уж что ж там — бывает, ладно.

Но поскольку исправление было сделано быстро, очевидно, что оно довольно тривиальное, и бэкпортировать его на семерку несложно — просто применить патч. Однако соответствующие просьбы были проигнорированы. Получается, что для исправления багов двухлетней давности надо покупать обновление лицензии. Это, мягко говоря, неприятно. :(
На самом деле бэкпортировать на семерку (или любую другую версию) как раз очень сложно — платформа постоянно изменяется и разрабатывать под две версии платформы очень накладно с точки зрения ресурсов — ведь помимо решения данной проблемы пришлось бы бэкпортировать куски кода, которые затрагивали внутренний API или другие подсистемы, тесно связанный с этой.
Только что понял, что и бэкпорт бы не помог — закончившаяся лицензия, оказывается, не распространяется даже на багфикс-релизы (мой 7.1.3 не предлагает обновляться на 7.1.4).

Обидно. Из списка новых фич мне ничего не нужно, а баги почти двухлетней давности, мною же отрепорченные еще при тестировании EAP6, несколько бесят. Я, конечно, за это время привык оформлять код так, чтобы их обойти, но со сторонним кодом-то так не сделать.
Закончившаяся лицензия распространяется на 7.1.4, но мы специально не делали этот апдейт обязательным/рекомендуемым с 7.1.3, так как в 7.1.4 появилась возможность логиниться в IDE с помощью JetBrains Account, что нужно не всем, а других фиксов там не было.
А, ясно! Тогда я все еще хочу бэкпорт. :)
Уточните пожалуйста, обычное renew для версии 7.1.3 сделанное после 16 сентября позволит работать с версией 8?
Да, любое обновление или новая лицензия после 16-го сентября 2013 позволяют обновиться до 8 версии.
Надо же, купил лицензию 27 сентября 2013 и успел на этот релиз) Но обычно использую EAP-версии. Из этого вопрос, сейчас EAP-8, 138.2071 от 5.09.2014, но релиз 138.2000 от 16.09.2014. Мне нужно качать релиз, или стоит продолжать использовать EAP версию, на этом канале будут обновления после релиза?
Стоит качать релиз — в данном случае номер билда был изменен по техническим причинам и 138.2000 старше 138.2071 (они из разных бранчей, если вдаваться в детали). Но EAP к 8.0.1 и следующим также будет в EAP канале конечно.
EAP закрыта навсегда?
EAP к 8.0 — да, а вот EAP к апдейту 8.0.2 будет открыта через пару недель.
А какая-то информация про phpdbg когда будет? Можно хоть как-то кратко описать какая сейчас ситуация, а то статус «в реализации» (уже который месяц? пол года, больше?) как-то удручает.
Скажите, пожалуйста, могу ли я сделать Renew, а не полную покупку, и каким образом (лицензия Open Source или коммерческая): сейчас у меня лицензия Open Source на вот этот проект: ClosureTable. Скажем так, сам код я не обновлял там месяца три, но этой библиотеке периодически народ ставит звездочки и почти постоянно количество скачиваний растет.
По поводу Open Source у нас все расписано подробно здесь, но для получения (или продления) OS лицензии звездочек и скачиваний не достаточно — нужна именно активная разработка. Можно написать по адресу, с которого вам приходила Open Source лицензия и узнать, можно ли продлить — каждый проект проверяется отдельно. Renew коммерческой лицензии можно сделать на сайте.
Планируется ли нативная поддержка фреймворка phalcon?
В ближайших планах поддержки точно нет. А что именно из поддержки хочется? У нас в трекере разумно расписанных запросов по phalcon не так много.
Попытался воспользоваться remote interpreter via ssh (PHP version: 5.6.0-1+deb.sury.org~trusty+1), но получаю такую бяку:

ssh://bitnami@192.168.1.40:22/usr/bin/php5 C:\Users\Administrator\PhpstormProjects\untitled\test.php Could not open input file: C:UsersAdministratorPhpstormProjectsuntitledtest.php bash: line 0: cd: C:/Users/Administrator/PhpstormProjects/untitled: No such file or directory

Все бэкслеши скипаются — это баг или я криворукий?
Проверил на Vagrant — то же самое.
bash: line 0: cd: D:/Projects/web/test2: No such file or directory
Could not open input file: D:Projectswebtest2test2.php
Проверено под Windows Server 2012.
Сорри, у меня руки кривые. Надо прописывать vagrant instance folder.
markdown в phpdoc-е это отлично конечно, еще бы распознавание инлайн-тэга {link} в описании param-property и тд допилили и phpdoc стал бы значительно полезнее, давно ведь висит уже youtrack.jetbrains.com/issue/WI-17985, еще есть похожие заявки.
С {link} вообще интересная история — в param-property если вставить {link} в ту же строку то он вообще не распознается, а если сделать перенос строки, то начинает нормально распознаваться — таким лайфхаком и приходится пользоваться, однако с method и эта фишка не проходит, к сожалению.
Там много нюансов, и что касается конкретно PHPDoc, то мы все же стараемся следовать формальной спеке, которая уже почти принята (пояснения по упомянутому тикету здесь). А так — да, есть некоторое количество багов, и мы стараемся бороться с ними изо всех сил.
Поздравляю с выходом новой версии, с удовольствием пользуюсь вашей IDE и рекомендую другим.

Пользуясь случаем хотел бы уточнить один момент по работе с SASS: есть ли возможность указать пути по которым стоит искать SASS библиотеки? Или поддержкой Compass всё ограничивается?

Use case: в проекте используется SASS+Compass+Susy+Breakpoint, всё установлено локально в проект через Bundler. Поддержка Compass включена в проекте, Susy и Breakpoint подключены в config.rb. Через командную строку всё компилируется отлично, но в IDE ни один из миксинов Susy не виден, а хотелось бы.
Спасибо! Уточнил у коллег — проверили.
Список нужных миксинов в completion присутствует:

Но есть инспекция “…resolved only by name…”.
Единственное место, где указана библиотека – это config.rb файл: require 'susy' — этого достаточно, чтобы соответствующий gem подхватился как библиотека.

Так что должно все работать, а если все же нет, то нам понадобятся логи в трекер и более подробная информация о настройках.
Проверил на отдельном тестовом проекте — действительно работает, буду разбираться дальше, спасибо.
Мне не удалось найти способ, чтобы hotkey работали в русской раскладке. Проблема актуальна для Ubuntu 14.04. Может быть есть такая настройка в IDE?
Пока невозможно, к сожалению — больше информации есть в соответствующем тикете. Но там вроде бы не всегда такое происходит.
А скажите, в релизе заработает автоформатирование шаблонов blade, как HTML?
Пока не сделали, но постараемся его сделать к одному из минорных апдейтов 8ки. Следить за статусом можно здесь.
WI-17801 тоже в свое время обещали пофиксить в минорном апдейте 6-ки. :/
Попробуйте еще раз, пожалуйста — была проблема с кешами после публикации апдейта 8.0.1, сейчас все проблемы решены.
Наконец-то можно открыть одиночний файл!
Хотелось бы узнать, когда поддержка PHP 5.6 появится в плагине PHP для IDEA.
PHPStorm использую уже несколько лет, очень доволен.

Был до последнего времени.

После установки 8-й версии PHPStorm с воплями и матюгами вернулся к 7-й: восьмая не работает с SVN, на которой я и процветаю — «unknown CVS». В списке доступных систем контроля версий Subversion исчезла.

Это такой мощный маркетинговый ход — или локальная ошибка «только у меня»?
Похоже на локальную проблему — все есть:


Может быть куда-то делся плагин в Settings | Plugins? Там должен быть включен плагин Subversion Integration.
Спасибо, гляну. У вас под Виндой установка или под Маком?
Под Маком, но я уверен, что на Винде все так же — кросс-платформенность выражается у нас как в самом продукте, так и во всех плагинах, так что они доступны на Win/Lin/Mac без дискриминации какой-либо из платформ.
Спасибо, буду тогда смотреть, в чем причина на машине.
Без обид, но использовать SVN — это как сейчас писать на бейсике — в своё время было революцией, но в нынешнее время — вызывает только чувство ностальгии. Не думали переехать на более современные системы?
> Не думали переехать на более современные системы?

Данный аспект вне моих рабочих полномочий. Плюс, технической необходимости в таком переезде де факто нет.
Не подскажете, когда Gherkin станет поддерживать русский язык? В тестах на русском («Пусть», «Тогда», «Сценарий» и т.д.) не работает ни расцветка синтаксиса, ни ctrl+click переходы.
Если ключевые слова заменить на «Given» и т.д. — все начинает работать как нужно.
Честно говоря уж и не знаю куда податься, видимо на багтрекер ваш вы все дружно забиваете, потому что как критичные баги могут висеть по 2-4 месяца мне не очень понятно (хотя выше вон говорили и про двухлетний критичный баг), и говорю я сейчас вот про эти два: WI-23442 и WI-24357. Куча голосов, что за один, что за другой, народ недоумевает, но они как висели так и висят. 24357 так и вообще полностью сводит на нет одну из основных фишек PhpStorm 8: поддержка Blade шаблонов. В связи с этим вопрос: доколе?!
Спасибо, мы знаем об этих двух issue и обе из них помечены к работе в версии 8 (в минорных апдейтах). Багтрекер при этом является основным средством коммуникации по подобным проблемам — могу Вас уверить, что на багтрекер в JetBrains никто и никогда не забивает.
Подскажите будет ли реализована нормальная работа folding кода? чтоб при различных манипуляциях блоки не разворачивались пока сам их не разверну? в частности html и jade кода. кстати почему нельзя сворачивать контейнеры в jade вида .classname а только div.classname?
Проблемы такого рода для каждого языка решаются отдельно. И не всегда вообще можно сохранить фолдинг — бывают изменения, которые нарушают структуру существующего кода, и не совсем понятно, как при этом сохранять состояние блоков. Но вообще информации маловато, пожалуйста, пришлите конкретный пример кода к нам в саппорт: intellij-support.jetbrains.com/anonymous_requests/new.
Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.