Pull to refresh
-1
Karma
0
Rating

Chrome Remote Desktop. Удаленная поддержка

на убунте работало как раз и не очень-то корректно, например:
у меня в хроме стоит открывать последние открытые вкладки и после установки chrome remote desktop вкладки сбрасываются, в том числе закрепленные. Ну и до кучи — не запускается терминал, который по умолчанию по ctrl-shift-t.
что бы это победить надо было прикладывать патч:
chrome-remote-desktop.patch
--- chrome-remote-desktop.orig 2018-12-27 11:11:40.312334408 +0300
+++ chrome-remote-desktop 2018-12-27 11:16:27.995436272 +0300
@@ -75,7 +75,7 @@
# with large or multiple monitors. This is a comma-separated list of
# resolutions that will be made available if the X server supports RANDR. These
# defaults can be overridden in ~/.profile.
-DEFAULT_SIZES = "1600x1200,3840x2560"
+DEFAULT_SIZES = "1920x1080"

# If RANDR is not available, use a smaller default size. Only a single
# resolution is supported in this case.
@@ -101,7 +101,7 @@
SYSTEM_SESSION_FILE_PATH = "/etc/chrome-remote-desktop-session"

X_LOCK_FILE_TEMPLATE = "/tmp/.X%d-lock"
-FIRST_X_DISPLAY_NUMBER = 20
+FIRST_X_DISPLAY_NUMBER = 1

# Amount of time to wait between relaunching processes.
SHORT_BACKOFF_TIME = 5
@@ -433,8 +433,8 @@
"""Return a candidate display number for which there is currently no
X Server lock file"""
display = FIRST_X_DISPLAY_NUMBER
- while os.path.exists(X_LOCK_FILE_TEMPLATE % display):
- display += 1
+ #while os.path.exists(X_LOCK_FILE_TEMPLATE % display):
+ # display += 1
return display

def _init_child_env(self):
@@ -720,8 +720,10 @@
self._init_child_env()
self._setup_pulseaudio()
self._setup_gnubby()
- self._launch_x_server(x_args)
- self._launch_x_session()
+ #self._launch_x_server(x_args)
+ #self._launch_x_session()
+ display = self.get_unused_display_number()
+ self.child_env["DISPLAY"] = ":%d" % display

def launch_host(self, host_config, extra_start_host_args):
# Start remoting host


что делать при каждом обновлении надоело.
в общем месяца два назад снес, и больше не проверял, может уже и пофиксили

Опасная лёгкость, с которой можно обмануть военный искусственный интеллект

Из $718 млрд долларов, запрошенных минобороны на 2020 год, $927 пойдёт на ИИ и машинное обучение

что? откуда еще 209?

Тренинг Cisco 200-125 CCNA v3.0. День 35. Динамический протокол транкинга DTP

Было:
ba(config-if)#do sh run int GigabitEthernet1/0/2
Building configuration...

Current configuration : 123 bytes
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
end


делаем:
ba(config-if)#switchport trunk allowed vlan remove 1

стало:
ba(config-if)#do sh run int GigabitEthernet1/0/2
Building configuration...

Current configuration : 161 bytes
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4094
switchport mode trunk
spanning-tree portfast
end

«Щенячьи глазки»: 30 000 лет коэволюции собаки и человека

Первобытные люди были прагматиками — сдохла собака, выкинул подальше, чтобы не воняла и все… К тому же собаки скорее были, как бы принадлежащие племени, а не лично кому-то.
Я про более позднее время, когда появиось какое-никакое разделение на бедных-богатых. Кто побогаче — хоронился с мечами, лошадьми, собаками.
Я вот про это:
Совсем иными были гробницы скифских царей и знати. Тело умершего царя, натертое воском и различными ароматическими травами, возили по всем территориям подчиненных племен для прощания. После этого оно доставлялось на специально отведенное для погребения место. Могилу вырывали чаще всего в виде четырехугольной ямы. Сверху ямы или в самой яме над телом покойного воздвигали деревянный сруб. Затем следовали каменная и земляная округлые насыпи, образовывавшие достаточно высокий курган. Часто вместе с царем хоронили слуг и верховых лошадей. В богатых скифских курганах нередко находят скелеты убитых наложниц и слуг — они сопровождали царя в загробный мир. Геродот рассказывает, что вокруг могилы царя расставляли чучела коней и сажали на них убитых юношей.

«Щенячьи глазки»: 30 000 лет коэволюции собаки и человека

а на чем хозяин будет ездить на том свете и с кем охотиться?

«Щенячьи глазки»: 30 000 лет коэволюции собаки и человека

Питомцев не убивали после смерти их хозяев, не переживайте. Собака умирала собственной смертью и ее хоронили в могиле хозяина.

Да ладно? Лошадей-жен убивали, а собак нет?

Восемь малоизвестных опций Bash

cdspell

Как по мне — вредная опция.
К примеру:
mkdir abcdefg
cd abcdeg
rm -rf *

сто раз я удалю файлы из каталога abcdefg, а потом в текущем каталоге окажется папка abcdeg…

Все таки скрипт должен делать то, что я попросил, а не то что имел ввиду.

Краткая история 3D-текстурирования в играх

на 3dfx примерно так и выглядела… только водичка похуже была

Прошивка Сisco CP-7906/7911

Вот это технологии. Все для людей.


А перевод звонка в 7911 та еще ламбада. :)

Прошивка Сisco CP-7906/7911

Ищешь торрент трекер с прошивками, ведь с официального сайта их скачать нельзя.

не правда, я качал с cisco.com. Там поискать правда нужно.
Выбираешь правильную версию прошивки с SIP (последняя не подходит в ней сломан SIP), не ошибись случайно выбрав версию с SCCP или MGCP

ну тут как повезет, с моими 30-ю 7911 никаких проблем с последней прошивкой.
Поднимаешь DHCP сервер и накручиваешь опции с указанием TFTP сервера

две строки в конфиге. делается один раз и навсегда.
Запускаешь TFTP сервер и кладешь прошивку по правильному пути с нужным именем.

см. выше
Гуглишь специальную секретную комбинацию вроде *#123123123# в котором телефон действительно скачает прошивку а не сделает что-то неправильно.

на cisco.com есть документация, которую нужно нагуглить, это да.
Пишешь три конфига: SEP<MAC-адрес>сnf.xml, даилплан (не помню как называется файл) и еще какой-то. Суешь их на TFTP сервер.

dialplan.xml и sipdefault.cnf один на все телефоны.
В качестве решения советуют держать SIP-сервер в локальной сети с телефонами.

Бывает иначе? Можно подробнее этот момент?

P.S. 7965 у нас нет, есть один 7945. Я его воткнул в сеть, поправил конфиг и зыбыл про то, что он вообще есть.

Альтернативная схема метро Минска

тут я думаю, что при объявлении станций стоило бы еще и номер говорить

Альтернативная схема метро Минска

а у нас метро нет, чему завидовать?
вот была нормальная же карта: image, и названия на месте и номера есть…

Мифы и отговорки, которые мешают учить английский

а действительно, как перевести на английский фразу «Зеленая зелень зеленит зеленую зелень»?

Крепкий середнячок: обзор IP-телефона Snom D735

корпоративность?
астериск бесплатен и достаточно прост даже для такого идиота, как я.
А вот личный скайп в рамках одной конторы как? или вацап?
наш 13-й астер умеет в видеозвонки, и они даже работают… зачем вацап, скайп или что там есть еще?

Крепкий середнячок: обзор IP-телефона Snom D735

по правде говоря, про snom первый раз слышу…
у нас повсюду cisco…

Американская компания уже год чипирует своих сотрудников. Почему за этим может быть будущее

По моему, это в штате Вашингтон, пересекающие границу штата с целью совершения преступления обязаны сообщить об этом властям. И это не глупый закон, он позволяет добавить еще одну статью в обвинение и приладить дополнительно пару-тройку лет к отсидке. Таким образом боролись с любителями махнуть в соседний штат, ограбить бензоколонку, да и свалить обратно, пока суть да дело. Типа полномочия полиции распространяются только на тот штат, в котором они служат…
Только вот сегодня, уж если полиция за кем-то погналась — на границы штата никто внимания не обращает, дожимать до конца будут, еще и подмогу из местных позовут :)

Илон Маск – это не будущее

пускай без станков, но ведь кроме здания там еще и коммуникации были и электричество и канализация и наверняка много всего еще.

Илон Маск – это не будущее

А какой это автозавод построил маск? Не тот который во Фримонте? Ну, который до 82 года (1982, карл!) представлял из себя сборочный цех General Motors? И который в 84 передали совместному предприятию GM и Тойоты, а потом в 2009 готовый завод перепродали тесле. Построил, ага…
Кстати, а сколько инженеров наса в SpaceX?

Как правильно измерять скорость интернет-канала и перестать выглядеть дурачком в глазах своего провайдера

Расскажу и я смешную историю:
Лет 7 назад при переезде в новый офис нам предложили протянуть оптику и мы согласились.
Пришли прекрасные парни, дотащили провод, повесили розетку на стену и выдали железку. Сразу договорились о том, что железка в режиме бриджа, на сервере PPPoE. Настраивать железку самим смысла нет — настройки провайдер заливает удаленно.
Все работало прекрасно недели две, потом сессия рвется и не поднимается минут 40, а то и больше, и так несколько раз подряд. В это время в логах ничего нет, как будто на том конце просто нет ответа.
Звоню по известному всем белорусам трехзначному номеру, саппорт сходу проблему решить не может, договариваемся о приходе завтра ребят с новой железкой.
И завтра приходит парень, и ставит новую железку, и проверяет уровень сигнала в оптике (с которым впрочем все в порядке). Симптомы те же: обрыв и молчание. На следующий день парней уже двое, третья железка, в логах странные записи — то уже кто-то подключился, то попытки подключения слишком частые, и надо подождать 5 минут между попытками. По телефону поступает предложение прошить железку новой прошивкой.
— Давайте, говорю, шейте.
— Ок, отвечает любитель новых прошивок, через минуту роутер ребутнется.
Проходит 5 минут, 10… Звоню с вопросом — когда?
— Да я уже перешил и перезагрузил, говорит.
Тут уже выясняется, что все это время этот интеллектуал занимался вовсе не нашей железкой, а даже неизвестно чей.
В общем минут через 20 он сдался и соединил меня с каким-то мега-спецом (вот тут без сарказма). Тот задал пару вопросов, постучал по клаве, тихо сказал «женщина вступающая в интимные отношения с каждым желающим», опять постучал по клаве и все заработало снова и работает до сих пор.
Спасибо тебе, неизвестный герой…
P.S. Парни так спешили уйти, что забыли забрать с собой лишний роутер, так он у нас в шкафу 7 лет и лежит…

OSPF (часть первая)

на первой картинке с «show ip ospf neighbor» DR — 4.4.4.4, 1.1.1.1 и 2.2.2.2 — DROTHER, а BDR нет вообще…
откуда тогда: «Как мы можем увидеть, DR — 2.2.2.2, BDR — 1.1.1.1, а с vIOS4 выбрано состояние 2WAY/DROTHER»?
Я не в ту картинку смотрю?
1

Information

Rating
5,894-th
Registered
Activity