Comments 16
Я на айфоны перешел около месяца назад, видимо я не в курсе чего-то… Просветите!:)
это воспоминание не связано с айфоном и с эпплом вообще. это я про vc++ :)
Да сделали бы просто растяжение картинки — один фиг, полное УГ.
Вопрос. Как мне тестировать приложение, которое одно и для iPhone и для iPad, в симуляторе iPhone?
Сейчас XCode под рукой нету, но насколько я помню просто выбираете при билде в выпадающем меню «симулятор 3.1.3» для айфона и «симулятор 3.2» для айпада. А в настройках Base SDK ставите 3.2.
Там проблема в том, что для iPad нужны UIPopoverController. Если выбирать 3.1.3, то оно, естественно, не компилируется.

Сейчас вставил немного условной компиляции, но все-равно, нужно бы потестить, можно ли, например, Ad-Hoc версию поставить на iPhone. Хочется одно приложение и там и там.
В общем-то да, проверьте на ad-hoc на айфоне, если есть такая возможность.

Чтобы классы специфичные для 3.2 компилировались для айфона тоже — попробуйте выставить base sdk в 3.2, а потом поэкспериментируйте с настройками таргета. Думаю, решение кроется где-то там.
Я напишу статью на TouchDev.ru после реального порта (сейчас свое приложение портирую), следите, если это интересно. Сюда — кармы (или что тут нужно) не хватает писать.
Храним переменную UIPopoverController * как id.
А код для создания экземпляра вот такой —
Class classPopoverController = NSClassFromString(@«UIPopoverController»);
if (classPopoverController)
{
popoverController = [[classPopoverController alloc] initWithContentViewController:masterViewController];
}
Сколько возьмете рублей для адаптации приложения на практике?
Only those users with full accounts are able to leave comments. Log in, please.